Page 1 of 1

MRS-1608 Input Problems - Please Help

Posted: Sat Jun 26, 2010 9:56 am
by SamuelStorm
Like most posts start out here...

I recently got an MRS-1608 on Ebay...

I have read, re read, looked at forums, checked cables, done everything I was supposed to do for plugging into the INPUTS at the back of the console. The only sound I get is from the demo, and the two front 1/4" Guitar 1/2 Inputs...

What I need to do is get the 1/4"/XLR Inputs on the back to work...

Please Help!

-Sam
Pennsburg, PA

Re: MRS-1608 Input Problems - Please Help

Posted: Mon Jun 28, 2010 9:00 pm
by Unstablxxx
Hey Sam, welcome to the forum. I have an 802, not a 1608, so any
advice I give you, take with a grain of salt.

I downloaded the manual for your unit and it appears that, in order
for the rear inputs to be active, you need to be in '8-track recording
mode'. Check out page 45 of your manual, I think the answer may be there.

Once you have '8-track recording mode' selected, then make sure you
have the on/off keys in the input section lit for the proper inputs.

Then select which tracks to record on and off you go. I hope. :)

Good luck.

Mike

Re: MRS-1608 Input Problems - Please Help

Posted: Tue Jun 29, 2010 8:56 pm
by SamuelStorm
Thanks Mike...

I also have the manual and tried that as well... I am awaiting a recovery cd from Samson and was told to try that and follow the same directions. If it doesn't work i was told to call them back & they would go through it with me again to see if it warrants having it brought in for repair.

Personally I am shocked & pleasantly surprised by their customer service on a discontinued product. I pray to the Gods of electronics & music that it works!

Re: MRS-1608 Input Problems - Please Help

Posted: Thu Aug 05, 2010 4:25 pm
by donsnut
have ou tried turning off the phantom power buttons in 3/4 and 5/6?

Re: MRS-1608 Input Problems - Please Help

Posted: Sun Oct 31, 2010 2:28 am
by chivalry1978666
I have been working with a 1608 pretty solid the past 3 months so I may be able to offer you some suggestions....and I know this may sound simple but you would be surprised how often I and others forget to do this...

First plug something into imput 1. Now press the imput 1 button should be red

Second press the track button one till it is red. also make sure you have the track fader to about -20 as well as the master fader.

third start playing if still not hearing anything increase gain and or recording level.

Fourth and Im surprised no one asked this do you have pwr audio speakers cause if you dont you may not get anything off of it.

If after all that your still not getting anything well then either your recording level is shot on 0 or your imputs are fried...best of luck

Re: MRS-1608 Input Problems - Please Help

Posted: Mon Feb 13, 2017 1:12 pm
by Sarg1965
Hi....having similar problem with my 1608.... none of the rear input jacks work...no phantom power....only the front two input jacks work. Have checked internal connection lead to board and it is intact.....no obvious signs of circuit board damage...any help on this fault would be great...thanks

Re: MRS-1608 Input Problems - Please Help

Posted: Tue May 09, 2017 1:07 pm
by LulaNord
Hi...i am a new user here. As per my knowledge in order for the rear inputs to be active, you need to be in '8-track recording mode'. Check out page 45 of your manual, I think the answer may be there.Once you have '8-track recording mode' selected, then make sure you have the on/off keys in the input section lit for the proper inputs.

pcb prototyping