Help H5 screen/device only works if power button held continuously

Discuss the Zoom H6, H5, H4, H4n, H2, H2n, and H1. Please don't "post and run". Participate in the discussion. Thanks.
Post Reply
new to this board
new to this board
Posts: 6
Joined: Sat Dec 31, 2011 9:49 am

Help H5 screen/device only works if power button held continuously

Post by missinglink » Sun Apr 29, 2018 11:31 am

Hello, can anyone help?

My H5 will only power up and go through the loading procedure if the power button is continuously held at the on position.

As soon as I let go the screen (and device) go off.

I have tried :
Holding the power button for different durations (1 sec up to 2 mins!)
Pressing most of the other buttons both as I power it up and after I power it up.
Fresh batteries, USB power.
With and without an SD card in.

The boot up time is considerably longer than when it worked.
After the initiall search screen (holding for about 10secs) the entire screen goes black for 2 secs and then the recording meters show and headphone volume.
It will read the contents of an SD card and show current time left and current settings.

No other buttons work on the device - only the power when held.

This unit has been used about a dozen times - usually with 2 external mics in addition to an XY capsule always off batteries.
I have had zero issues so far.

The fault occurred when part way through a session I removed the batteries to change them - then the unit would not power up as normal.

Any ideas - thanks for reading anyway. I think I may need to buy a replacement :(
0 x

User avatar
Jedi Zoom Master
Jedi Zoom Master
Posts: 1046
Joined: Mon Aug 13, 2007 4:34 pm

Re: Help H5 screen/device only works if power button held continuously

Post by Jim_Fogle » Sun Apr 29, 2018 5:24 pm

Your description reads as though the hardware is fine. I would try 1) installing, formatting and using a different SD card and 2) flashing the firmware ... #downloads before I'd spend the money for a second device.

For the record your description reads like your device is caught up in some sort of software loop. My thought is changing SD card or flashing the firmware MIGHT break the loop.
0 x ... tent=music
Zoom MRS-8
Gibson acoustic 12-string, Peavey Predator, Line6 Variax, Yamaha keyboard and digital drums
2018 Band-in-a-Box, ChordPulse
Cakewalk by BandLab, Sonar Home Studio, Cakewalk Music Creator 6, Audacity
Win 7 laptop i3, 8 GB DRAM, 500GB SSD

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests